Health Check Error: Incompatible module

    Overview

    The Health Check wizard must be run when upgrading to evaluate whether your instance is suitable for upgrade. During the health check, various types of issues may be detected which can affect your ability to upgrade. This article will cover the “Incompatible module” error reported by the health check.

    Symptoms

    This error generates an output similar to the following in health check:

    image1

    Resolution

    The Feeds and iFrames modules are fully deprecated and not supported in Sugar 7.x and above. These modules may appear in your 6.x instance of Sugar as “RSS” and “My Sites” respectively. In Sugar 6.x, the modules were enabled by the following files:

    • ./custom/Extension/application/Ext/Include/Feeds.php
    • ./custom/Extension/application/Ext/Include/iFrames

    During the upgrade, these files are disabled by being relocated to ./custom/Extension/application/Ext/Disabled/ and the modules will no longer be accessible by your users.

    in Troubleshooting Health Check Output

    Reach out to us for help